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Outline 

•  Part 1: Content 
–  Motivations and audience 
–  Scheduling 
–  Assembling content 
–  Creating figures and tables 
–  Writing 
–  Language, words, names, and references 

•  Part 2: Implementation 
–  Editing tools 
–  Formats and templates 
–  Figures and tables 
–  Footnotes 
–  Cross-references 
–  Comparing documents 
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Part 1: Content 

•  Motivations and audience 
•  Scheduling 
•  Assembling content 
•  Creating figures and tables 
•  Writing 
•  Language, words, names, and references 
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Motivations 

•  Engineering specifications serve several functions: 
–  Specify how a design shall be implemented. 
–  Clarify agreements on design goals and methods. 
–  Tutorial for new members of an engineering team. 
–  Starting point for other documents  

(patent applications, presentations, technical 
manuals, user guides, training scripts ...). 

•  For each function: 
–  Audience may have different needs and expectations. 
–  Content may need to be modified or expanded. 
–  Ease of modification depends on how well the original 

specification is written and formatted. 
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Identify the Audience 

•  Audiences have different knowledge than you: 
–  They may not know details of your ideas or product. 
–  They may not know all of your names and acronyms. 
–  They may have different questions than you have. 
–  They may not understand the English language well. 

•  Before you start, ask: 
–  What are the skills and interests of your audience? 
–  What do they need to know? 
–  Imagine yourself as the audience, and speak to them. 

•  Start by writing an unordered list of topics: 
–  Then order the list for flow, from general to specific. 
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Estimate a Schedule 

•  Start with an approximate schedule: 
–  Plan and assemble source material: 5% of total time. 

•  Those you understand best and can articulate most quickly. 

–  Draft #1 and Review: 85% of total time. 
•  Make the first draft look like the finished document. 

–  Draft #2 and Review: 5% of total time. 
•  Identify and fix all errors and omissions. 

–  Final (no review): 5% of total time. 
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Assemble Content 

•  Find in-house sources: 
–  Your own knowledge or hands-on use. 
–  Hands-on use, or interviews with colleagues. 
–  Engineering specifications, presentations, patents. 

•  Find external sources: 
–  Industry journals, technical textbooks, competitors’ 

publications. 
–  Search your bookshelf, the Internet, or a library. 

•  Assess the quality of sources: 
–  Is their content similar or relevant to your topic? 
–  What content is missing from the sources? 
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Create Figures and Tables 

•  Create figures that summarize your text: 
–  Begin each section with an overview figure. 
–  Create figures in two different ways: 

•  Translate a summary of your text into a figure. 
•  Create a figure, and then write text to explain the figure. 

–  Start by hand-sketching rough figures. 
•  Later, implement the sketches in a drawing application. 

•  Create tables that augment or summarize your text: 
–  Create matrices that define and compare parameters. 
–  Use tables as cross-references and indexes that help 

readers random-access content quickly. 
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Start Writing 

•  Create a list of topics (the “Outline”): 
–  Start with an unordered list, writing down any topics 

that come to your mind, in any order. 
–  Then, order the list for flow, from general to specific. 

•  Fill in the content: 
–  Write the easiest sections first: 

•  Those you understand best and can articulate most quickly. 

–  Begin each section with an overview. 
•  Summarize context, function, purpose, control, resources. 

–  Build the document, following your list of topics. 
–  Define acronyms and special terms up front. 
–  Don’t get writer’s block – just start writing. 
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Language 

•  Use clear, simple language: 
–  Every sentence needs a subject (noun phrase) and a 

predicate (verb phrase). 
•  Wrong: “The Stop bit is set at boot time”. The predicate (“is 

set”) is incomplete. It does not say what performs the action, 
e.g., software or hardware. 

•  Right: “Software must set the Stop bit at boot time”. 

–  Write sentences that can be read fast.  
•  Shorter sentences, simpler words.  

–  For most readers, English is a second language. 
•  They appreciate simplicity and clarity.  
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Words 

•  Avoid ambiguous words and symbols: 
–  What does “MSB” mean? 

•  “Most-significant byte”, or “most-significant bit”?  
•  Does it specify not only memory ordering but also what 

comes first-in-time on a serial link or a parallel bus? 

–  Does slash (/) mean AND, OR, or AND-or-OR? 
•  Some engineers are not clear about their use of this symbol. 

–  Do not use undefined abbreviations or acronyms. 
•  If you use them, define them on first use and provide a 

glossary at the beginning of the document. 
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Names 

•  Use names consistently: 
–  Here is an example: 

•  "An AND gate can be built from a NAND, and a NAND would 
require two less gates than an AND."  

•  So, what does “gate” mean? Is it the AND or NAND, or is it a 
subcomponent from which the AND and NAND are made? 

–  Always use the same name for the same thing: 
•  Pick one name for each thing: e.g., “function” or “block”. 
•  Use only that name; do not use aliases (synonyms). 
•  Undeclared aliases in computer programs result in errors. 
•  Human brains work like computer programs in this respect. 

–  This is a BIG problem in engineering specifications. 
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Compounds 

•  Compound Nouns and Noun-Modifiers: 
–  What does “ten tapped filters” mean? 

•  "ten filters with taps“? 
•  "filters with ten taps“? 

–  Add a hyphen to clarify the meaning: 
•  “ten-tapped filters” (hyphenate the compound noun-

modifier). 
•  “ten tapped-filters” (hyphenate the compound noun). 
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References 

•  Use clear references: 
–  What are “this” and “that” referring to? 
–  Example: 

•  “The disk drive makes a loud rattle when a programmatic 
branch causes the head to seek a distant track; this should 
be avoided.”  

•  So, what “this” should we avoid? 
–  Writing programs that have branches? 
–  Storing branch targets in distant disk tracks? 
–  A loud rattle, no matter how it is caused? 
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Part 2: Implementation 

•  Editing tools 
•  Formats and templates 
•  Figures and tables 
•  Footnotes 
•  Cross-references 
•  Comparing documents 
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Popular Editing Tools 

•  Writing tools: 
–  Microsoft® Word (Windows or Mac): 

•  Pros: price, widely used. Cons: learning curve, predictable 
control. 

–  Adobe® FrameMaker® (Windows): 
•  Pros: predictable control. Cons: learning curve, price. 

•  Vector-graphics tools: 
–  Microsoft Visio® (Windows): 

•  Pros: widely used. Cons: learning curve, productivity. 
–  Adobe Illustrator® (Windows or Mac): 

•  Pros: control, productivity. Cons: learning curve, price. 
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Popular Editing Tools 

•  Built-in drawing tools: 
–  Avoid using built-in Word or FrameMaker draw tools. 

•  Hard to control. 
•  Can’t be imported into other software tools. 

•  Tool versions: 
–  Have all contributors use the same tools and version. 

•  Formatting problems with cross-version Microsoft® Word. 
•  Especially important for international collaboration. 

•  Other tools: 
–  PowerPoint® is not a document-editing tool. 

•  No named formats, no cross-page text flow. 
•  May be useful for figures.  
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Formats 

•  Use predefined formats: 
–  For characters, paragraphs, page layouts, etc. 

•  If your company does not have predefined formats, tell your 
IT department about external collaborators.  

–  Otherwise, learn and use built-in formats in Microsoft 
Word or Adobe FrameMaker. 

–  Do not modify fonts or spacing of characters or 
paragraphs.  

•  Instead, apply a standard format.  

•  The following examples use these editing tools: 
•  Word 2010 for Windows (Mac 2011 is similar). 
•  FrameMaker 10 for Windows. 
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Formats 

•  Conventions: 
–  Do not use multiple tab characters to position text. 

•  Instead, use a predefined paragraph format. 

–  Do not use multiple carriage returns to position text. 
•  Instead, use a predefined paragraph format. 

–  Do not modify the font of an individual character. 
•  Instead, use a predefined character format. 

–  Use a small number of common fonts and font sizes. 
•  For example, use Arial or Verdana fonts, sizes 10, 11, or 12. 
•  Documents with many fonts or font sizes look chaotic. 
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•  Word 2010 for Windows: 
1. Select text. 
2. Home > Styles, for the Styles Gallery, or 
3. Home > Styles > Show Styles (lower-right corner of Styles tab) to 

open the Styles Window. 

Applying Formats 

1. 2. 
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Applying Formats 

•  FrameMaker 10 for Windows: 
1. Select text. 
2. Click the ¶CATALOG tab (Format > Paragraphs > Catalog…) 

and click the paragraph style. 
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Applying Templates 

•  Word 2010 for Windows: 
1. File> Options > Add-Ins... 
2. Select Templates from Manage drop-down list, and click Go... 
3. Click Attach... to browse and select a template. 

1. 2. 3. 
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Applying Templates 

•  FrameMaker 10 for Windows: 
1. File > Import > Formats… 
2. Select source file from Import from Document: pull-down menu, 

check properties to Import and Update, and click Import. 

1. 2. 
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Figures and Tables 

•  Conventions: 
–  Do not copy figures or tables from other applications 

and paste them into your Word or FrameMaker 
document. 

•  Instead, use the insert functions in Word or FrameMaker. 
•  Pasted objects may cause incorrect flow of text that is added 

or deleted.  
–  Use the standard method of inserting captions (titles). 

•  Otherwise, figures and tables cannot be cross-referenced 
correctly. 
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Inserting Figures 

•  Word 2010 for Windows: 
1.  Insert a carriage return where the figure will go. 
2.  Insert > Illustrations > Picture.  
3.  Select picture file, and click Insert or Link to File. 

1. 2. Result 
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3. 

Clicking Insert embeds a copy of the file. 
Clicking Link to File places a pointer to the file. 



Inserting Figure Captions 

•  Word 2010 for Windows: 
1.  Insert a carriage return where the figure caption (title) will go.  
2.  References > Captions > Insert Caption.  
3.  Select Label: Figure, enter Caption:, and click OK. 

1. 2. 3. Result 
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Inserting Figures 

•  FrameMaker 10 for Windows: 
1.  Turn on View > Borders (lets you see where the figure will go).  
2.  Insert a carriage return where the figure will go.  
3.  Special > Anchored Frame... 
4.  Select Anchoring Position: Below Current Line, and click  

New Frame. (See continuation on next slide.) 

1. 2. 3. Result 4. 
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Inserting Figures (continued) 

•  FrameMaker 10 for Windows: 
5.  Click on the anchored frame to select it. 
6.  File > Import > File... 
7.  Select the file, check Import By Reference, and click Import. 
8.  Select image resolution (e.g., try Custom dpi), and click Set. 

5. 6. 7. Result 8. 
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Inserting Figure Captions 

•  FrameMaker 10 for Windows: 
1.  Place cursor in the paragraph where the figure caption will go, 

and apply the appropriate format from the ¶CATALOG.  
2.  Enter the figure caption. 

1. 2. 

29 



•  Word 2010 for Windows: 
1.  Insert a carriage return where the table will go, and move cursor 

to the beginning of the next paragraph. 
2.  Insert > Tables > Table.  
3.  Drag and release mouse to select number of rows and columns. 
4.  Move cursor to paragraph above table, select References > 

Captions > Insert Caption. 
5.  Select Label: Table, enter table caption (title), and click OK. 

Inserting Tables 

1. 2. 3. Result 
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Inserting Tables 

•  FrameMaker 10 for Windows: 
1.  Move cursor to end of paragraph below which table will go. 
2.  Table > Insert Table...  
3.  Specify table parameters, and click Insert. 
4.  Drag cursor across all table cells to select them.  

(See continuation on next slide.) 

31 

1. 2. 3. 4. 



Inserting Tables (continued) 

•  FrameMaker 10 for Windows: 
5.  Table > Format > Resize Columns... 
6.  Choose By Scaling to Widths Totaling x.x”, and click Resize. 
7.  Place cursor in table-title paragraph, and enter a title. 
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Inserting Footnotes 

•  Word 2010 for Windows: 
1.  Place cursor at point of footnote insertion.  
2.  References > Footnotes > Insert Footnote, and click. 
3.  Type the footnote text. 

1. 2. 
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Inserting Footnotes 

•  FrameMaker 10 for Windows: 
1.  Place cursor at point of footnote insertion.  
2.  Special > Footnote. 
3.  Type the footnote text. 

1. 2. 
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Comparing Documents 

•  Word 2010 for Windows: 
1.  Review > Compare > Compare…  
2.  Browse for original and revised documents to be compared, and 

click OK. 
3.  Save the new document with a unique filename. 

 
Avoid using Track Changes with complex, multi-user documents.  

1. 2. Result 
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Comparing Documents 

•  FrameMaker 10 for Windows: 
1.  From within the first document (called the Newest Document),  

File > Utilities > Compare Documents...  
2.  Browse for the second document (called the Oldest Document), 

and click Compare. 

1. 2. Result 
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The Bottom Line 

•  Make your documents easy and fast to read. 
•  Make them easy and fast to maintain. 
•  Make them easy to adapt for other uses. 
•  Use standard procedures. 
•  Use predefined formats. 
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